Jump to content
ELFORUM - Forumul Electronistilor
Sign in to follow this  
CostelScrepnic

AJUTOR!!!!PICKIT2 CLONA

Recommended Posts

Am realizat montajul care l-a reazat și ADICONTACT(autor Suky) ,am scris hex-ul pe pic,piesele au valorile din schemă,dar cînd îi conectez la pc îmi dă mesajul*Unul dintre dispozitivele USB atașate la acest comuter s-a defectat și Windows nu îl recunoaște.ce să aibă,probleme de construcție sau hex-ulmulțumesc anticcipat.

Share this post


Link to post
Share on other sites

Verifica daca montajul primeste tensiune de la mufa USB, verifica corectitudinea conexiunilor PIC-mufa USB si rescrie fisierul hex in PIC.

Share this post


Link to post
Share on other sites

Mulțumesc mult pt. indrumări. Aș avea o rugăminte,care are un montaj funcțional să mi dea niște date tehnice(puncte de măsurare cu tensiunele respective).Se mulțumește.

Share this post


Link to post
Share on other sites

Am si eu o clona PICkit2.Te ajut cu placere, daca avem aceeasi varianta.A mea este cea de pe site-ul Kud***ko.fee.fr

Share this post


Link to post
Share on other sites

SALUTAREAm rescris HEX-ul și tot același mesaj imi dă. :sparge: Să fie de vină tranzistori BC 558(în loc de BC 558A am pus BC558C)? Altceva nu îmi dau seama ce ar putea fi,PIC-ul e nou nu din recuperări.

Share this post


Link to post
Share on other sites

Dupa cum te-a sfatuit colegul nico_2010, repet si eu:- verifica tensiunea de alimentare direct pe pinii microcontroler-ului, mai ales daca este pus in soclu.- nu vad perechea de condensatori de bypass la alimentarea uC-ului: pune direct intre pinii VDD si VSS ai uC-ului (daca e pe soclu direct pe pinii soclului) un condensator de 0.1uF in paralel cu un cond polarizat de 10uF ... 47UF.- verifica cu un ohmetru daca ai continuitate intre pinii din mufa cablului USB, cea Male-A(care intra in portul USB al PC-ului) si pinii 15, respectiv 16 ai microcontrolerului. Mesajul legat de conexiunea USB nu are nimic in comun cu tranzistorii din schema (decat daca i-ai pus invers cumva si acum ai probleme cu tensiunea de alimentare).- verifica condensatorul de pe pinul 14 (Vusb) sa fie pus corect (+ versus -). Este destul de critic, eventual foloseste condensator cu tantal.- verifica oscilatorul (cuartz + condensatori C4,C5) sa nu aiba "mustati" cuartzul. Daca ai posibilitatea verifica pe pinul 10 daca ai o oscilatie curata de 20MHz (cu un osciloscop). Comunicatia USB are nevoie de timing-uri foarte stricte, am un coleg care s-a lovit de probleme cu impendanta traseelor pentru semnalele D+ SI D-.SuccesLE: banuiesc ca ai rescris HEX-ul pe pinii de ICSP si nu prin intermediul bootloader-ului ... merita sa vezi daca intra in Bootloader (tine apasat butonuul Reset si apoi alimenteaza montajul -> ar trebui ca unul din LED-uri - nu mai tin minte care - sa "flashuiasca" cu o frecventa de cca 0.5 ... 1Hz).

Share this post


Link to post
Share on other sites

Ataseaza doua poze cu montajul, fata si spate. Sa vedem si noi ce este acolo, daca se poate...

Share this post


Link to post
Share on other sites

te voi ajuta eu, eventul cu depanarea ei completa. ti-am lasat mesaj privat.

Share this post


Link to post
Share on other sites

Am intrat in posesia programatorului de la initiatorul acestui topic, nu reusec sa ii dau de cale, am pus condensatori cum s-a zis aici, am tensiune pe Vusb, conexiunile sunt bune, ramane sa fie o problema de cablaj, ca nu e facut prin metoda cu fierul e facut cu smoala si seringa. Aceasi eroare primesc, nu intrat in bootloader, am rescris softul in pic, am incercat si cu alt pic si tot asa.

Share this post


Link to post
Share on other sites

Foloseste uC-ul lui (18F2550) in programatorul tau si vezi daca functioneaza.Dezlipeste toate componentele mai putin: uC-ul, oscilatorul, conzii de pe alimentare, cond-ul de pe Vusb. Conecteaza-te cu cablul USB direct pe pinii uC-ului.

Share this post


Link to post
Share on other sites

in programatorul meu merge, ca am testat asta, daca ma apuc sa dezlipesc toate componente nu le mai pot pune inapoi, se exfoliaza cablajul e de proasta calitate., am schimbat si cristalul de cuart.

Share this post


Link to post
Share on other sites

In acest caz ai gasit solutia: alt cablaj (daca e chiar asa de slab calitativ). Si inainte de replantarea componentelor, verificate fiecare individual.

Share this post


Link to post
Share on other sites

Asa este, trebuie refacut cablajul, nu am ce sa ii fac. am incercat toate solutiile. se pare ca nu porneste, daca nu intra nici macar in bootloader cu butonul de reset apasat.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.