Jump to content
ELFORUM - Forumul electronistilor

Sfaturi pentru driver TB6560


Recommended Posts

SalutareTocmai ce am realizat trei drivere pentru motoare pas cu pas cu tb6560Acum as vrea sa le testez dar nu vreau sa fac vreo prostie...Impulsurile pentru step si dir vor proveni de la o placa arduino uno...Dar apare o mica problema... din cate am inteles driverul este cam sensibil la scurt-circuitDaca inversez din greseala bobinele se va arde driverul?Dupa ce m-am cam documentat am aflat ca se poate folosi si un etaj de protectie format din 8 diode...La ce tensiune ar trebui sa il testez pentru inceput, 5V-12V.. la care e mai sigur?O alta chestiune ar fi testarea driverului... as putea face chestia asta cu o proba logica formata din 4 leduri care sa imi indice sensul curentului prin bobine?Multumesc si astept sfaturi cumintel :DAcum o sa ii montez radiatoarele si pe urma revin cu fotografii :d

Attachments_2012_11_29.zip

Link to comment
  • Replies 11
  • Created
  • Last Reply

Top Posters In This Topic

Multumesc pentru raspunsInitial o sa il alimentez la 5V si pe urma crescDriverul are rezistorii de putere de 0.5 ohmi ceea ce duce la un consum de 1 ATQ2 - high TQ1 - low determina un consum de 50% >> 0.5 Apentru siguranta sa ii setez pe amandoi high? (20%)Darmotorul are urmatoarele fire (in ordine):verde . rosu . negru . alb . verde cu alb . rosu cu alb .verde-verde cu alb = prima bobinarosu-rosu cu alb = a doua bobinacele 4 fire folosite le-am luat asa:verde cu alb . verde . rosu cu alb . rosuacest aranjament corespunde cu A1, A2, B1, B2 ?pe cablajul driverului mi-a iesit B2, B1, A2, A1...asadar ar trebui sa nu aiba probleme, nu?si daca o sa folosesc o punte de protectie din 8 diode (4 pe bobina - 2 spre Vcc - 2 spre Gnd)inlatur chestia cu Back-EMF si chestia cu inversatul fazelor?

Link to comment

ESTE VIU ! :da dar peste tot exista un dar...la 5v si TQ1 si TQ2 - high merge lin (dar fara putere)tot la 5v si TQ1 - low si TQ2 - high este blocat....daca o sa cresc tensiunea la 12V s-ar putea sa functioneze normal?codul e in felul urmator#define CLK_PIN 13#define ENABLE_PIN 11#define CCW_PIN 12void setup() {for (int i = 11 ; i <= 13 ; i++){ pinMode(i, OUTPUT); digitalWrite(i, LOW);}digitalWrite(ENABLE_PIN, HIGH);}int del = 750;int counter = 0;int dir = LOW;void loop() {// Send out a clock signal. switch the direction bit every 2000 clocks.digitalWrite(CLK_PIN, HIGH);delayMicroseconds(del);digitalWrite(CLK_PIN, LOW);delayMicroseconds(del);counter++;if (counter == 2000) {if (dir == LOW) {dir = HIGH;}else {dir = LOW;}digitalWrite(CCW_PIN, dir);counter = 0;}}Astept sugestii icon_jook Revin cu informatii dupa testare

Link to comment

pentru comanda folosesc un arduino unocomanda consta in step, dir, enablece e interesant ca totul s-a "schimbat" dupa alimentarea la 12V (de la o sursa de pc)ce e si mai interesant e ca al doilea modul functioneaza haotic (acu merge tot inainte dar cu pauze neregulate)in gol ar trebui sa aiba consum? ca ambele cam au...si am tinut cont si de faza cu alimentarea individuala si ordinea acestora...sincer nu prea mai stiu ce sa masor sau sa fac... :jytuiyu

Link to comment

revin din nou cu date...momentan testez pe al doilea modul icon_jook mersul haotic... era din cauza primului program... diferenta de timp intre pasi era de 750 usam marit-o putin si merge pe orice tip de combinatie TQ (dar consuma la stationare 1.7A / 5V)urmeaza sa testez acelasi lucru si pe primul modul... posibil sa nu fie ars... foarte posibil sa fie :|revin :)

Link to comment
  • 3 weeks later...

Legat de lucrul acesta am si eu am aceasi problema cu consumul in momentul in care motorul "sta". Driverele mele sunt cu FET-uri . Intrebarea mea este daca in momentul in care se opreste motorul (nu are comanda de step), el ramane alimentat pe ultimele bobine care au fost alimentate? Precizez ca driverele mele nu au enable iar motoarele consuma in jur de 1A. Mai clar vreau sa stiu daca in momentul in care alimentez driverele, este normal ca doua FET-uri sa fie deschise?Sunt super la inceput in acest domeniu al motoarelor pas cu pas, asa ca va rog sa aveti mila...:tryre Va multumesc!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines