Jump to content
ELFORUM - Forumul electronistilor

Probleme utilizare LCD


Guest david1

Recommended Posts

Guest david1

Salutare tuturor, De ceva vreme incerc sa folosesc un afisaj LCD dar orice fac nu vrea sa mearga. De fapt am folosit cateva macro-uri pentru LCD si le-am utilizat la un 16F84. Cu 16f84 functioneaza. Dar eu as vrea sa il folosesc cu 16F877 sau 16F77. Problema este ca afisajul nu vrea sa imi afiseze nimic. Cand ii dau simulare in Proteus, apar pe lcd cateva patrate negre dupa care nu mai afiseaza nimic. Care ar putea fi problema ? Atasez mai jos macrourile, fisierele .asm si schemele in proteus pe care le-am folosit. Ma poate ajuta cineva ? Va multumesc.

Link to comment
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Posted Images

Guest david1

Mersi, Stefan Nicolae, Realizez ca sunt un mare tolomac. De fapt am avut probleme si cu 16F84 si dupa ce am studiat bine macrourile folosite, am vazut in macro-ul LCD urmatoarele : ;******Declaring hardware ********** RS equ 1 RW equ 2 EN equ 3 Asa mi-am dat seama ca trebuia sa modific schema pe care de fapt am preluat-o de pe un site. Dar cand am ajuns la 16f877 am uitat care a fost problema. M-au obosit cu totul microcontrolerele astea. :sparge: Oricum nu ma dau batut. Mersi inca odata.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines