Jump to content
ELFORUM - Forumul electronistilor

Probleme cu Servomotoare


Guest stefan_TM

Recommended Posts

Guest stefan_TM

Am construit o masa de debitare cu plasma cu servomotoare Samsung de 400 w 2 pe axa y 1 pe x si 1 pe z.Axele sunt cu unitati de deplasare liniara cu surub cu bile 3x2x0.3 m. Problema este ca la o miscare simultana a axei x cu axa y nu traseaza corect curba. Ex in cazul unui cerc il traseaza oval deasemenea un triunghi nu are laturile obtinute din deplasarea ambelor axe drepte.Nu stiu de unde ar aparea problema din setarile srvodriverelor sau din setarile Mach.Servodriverele sunt tot Samsug.

Link to comment
  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Am construit o masa de debitare cu plasma cu servomotoare Samsung de 400 w 2 pe axa y 1 pe x si 1 pe z.Axele sunt cu unitati de deplasare liniara cu surub cu bile 3x2x0.3 m. Problema este ca la o miscare simultana a axei x cu axa y nu traseaza corect curba. Ex in cazul unui cerc il traseaza oval deasemenea un triunghi nu are laturile obtinute din deplasarea ambelor axe drepte.Nu stiu de unde ar aparea problema din setarile srvodriverelor sau din setarile Mach.Servodriverele sunt tot Samsug.

Du-te pe mach la setting (sus in dreapta), si vezi ca scrie calibrate axis. Da-i sa-ti mute 500mm la axa x (la fel si y), vezi cat ti-a mutat si scrie acolo. O sa te intrebe daca vrei sa-ti seteze automat si ii dai ok.
Link to comment
Guest stefan_TM

Mersi de raspuns dar nu aceasta e problema.Daca ii dau o deplasare de la x=0 y=0 la x= 500 y=500 atit se deplaseaza problema este ca nu se deplaseaza pe o linie ci pe o curba deci axele x si y nu merg sincron cred ca e ceva cu acceleratia si deceleratia (frinarea) pe cele 2 axe.Driverele sunt CSDJ PLUS 04 BX2 motoare sunt tifazice de 400w adevarul este ca pe axa x nu am reusit sa fac autotuningul automat la motor si am ajustat manual parametrii pina am obtinut zic eu o miscare OK.Pentru setarea servodriverelor am folosit SmartJog.

Link to comment
Guest dorinspeedy

Mersi de raspuns dar nu aceasta e problema.Daca ii dau o deplasare de la x=0 y=0 la x= 500 y=500 atit se deplaseaza problema este ca nu se deplaseaza pe o linie ci pe o curba deci axele x si y nu merg sincron cred ca e ceva cu acceleratia si deceleratia (frinarea) pe cele 2 axe.Driverele sunt CSDJ PLUS 04 BX2 motoare sunt tifazice de 400w adevarul este ca pe axa x nu am reusit sa fac autotuningul automat la motor si am ajustat manual parametrii pina am obtinut zic eu o miscare OK.Pentru setarea servodriverelor am folosit SmartJog.

Parerea mea, care nu lucrez cu Mach, este ca nu sunt setate bine driverele pentru servomotoare, privind vitezele si acceleratiile in taiere si in deplasarile rapide, mai ales in taiere, ar mai putea sa fie o problema de mecanica la axe sau suruburi si electronica sa nu compenseze destul de rapid, totusi folosind cu Mach servomotoare cu drivere specializate si nu MPP-uri poate fi o problema de feedback daca servomotoarele au encodere, bine ca se pot pune encodere si pe MPP, dar daca nu ai feedback in program totul e egal cu zero, la motoare servo cu encoder si drivere dedicate nu obtii nimic doar probleme, daca o axa da de greu sa zicem driverul ii da motorului curent pina ajunge unde trebuie dar cealalta care merge mai usor deja si-a facut treaba/cursa, teoretic un program serios ar trebui sa incetineasca si cealalta axa pana isi face treaba aia cu probleme, tinand cont ca la taiere cu plasma nu ai forte prea mari pe x si y totul poate sa fie din mecanica sau din setarea driverului pe o axa, mai mult nu stiu....poate acolo unde ai 2 motoare ai 2 drivere dar mecanic nu prea se sincronizeaza, ar trebui o sincronizare mecanica cumva cu o curea dintata...
Link to comment
  • 3 weeks later...

Verifica daca suruburile au acelasi pas.Verifica daca encoderele sunt identice pe X si pe Y.Verifica daca setarile in Mach sunt corespunzatoare (adica daca nr de pasi e corelat cu pasul surubului pe fiecare axa).Daca ai suruburi cu pas diferit sau encodere diferite, trebuie sa setezi corespunzator in Mach Stima.

Link to comment
  • 3 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines