Jump to content
ELFORUM - Forumul Electronistilor
Sign in to follow this  
bobtech

Releu comandat de iesire analogica

Recommended Posts

Posted Image

 

Am urmatoarea problema:

folosesc schema din imagine pentru a genera tensiuni 0-12V folosind iesirea analogica a unui microcontroler.

sursa de +15V poate da un curent de maxim 5A

sursa de -12V poate da un curent de maxim 1A

in gol, fara sarcina, la INPUT am o tensiune de +12V, la OUTPUT am +12V

 

vreau sa actionez un releu Omron de 12V cu rez bobinei de 150 Ohm (cosuma in jur de 90mA) si problema este ca atunci cand releul este conectat, tensiunea la iesire (OUTPUT) scade la 11V, iar daca folosesc mai multe etaje de acest tip cu cate un releu pe fiecare, alimentate de la aceeasi sursa in comutatie de +15V, tensiunea pe releu scade la 10V in cazul a 6 etaje cu releu si nu-mi pot explica de ce ?

 

poate sa ma ajute cineva ?

 

nu pot modifica nici schema nici releul, momentan vreau sa inteleg de ce se intampla asta.

 

10x

Share this post


Link to post
Share on other sites

Schema e gresita , nu asa se comanda un releu. Nu stiu de ce ai facut asa schema , nu-i nevoie de sursa de tensiune . Tranzistorul nu ajunge la saturatie ( aproximativ scurtcircuit ) , de asta tensiunea pe releu e mai mica decat alimentarea ( normal ar trebui sa ai 15V).Uite o schema corecta , oarecare ( tot cu microcontroler) , de comanda a unui releu , nici nu-i nevoie de operational . Tensiunea de alimentare trebuie sa fie egala cu cea a releului , deci 12V nu 15V ca in cazul tau.

Share this post


Link to post
Share on other sites

@Depanatoru'stiu si eu cum se comanda un releu cat mai simplu, nu ca as vrea eu sa ma complic.problema e ca am niste carduri cu iesiri analogice, al caror etaj de iesire arata ca in schema care am postat-o. au specificatii: iesire analogica 0...12V si curent maxim de 100mA pe iesire.tranzistorul nici nu ar trebui sa conduca la saturatie, el e comandat de opamp si iesirea ar putea urca si mai mult de 12V, doar ca la intrare e limitat la 12V. recunosc ca operationalele nu sunt punctul meu forte, vroiam sa stiu motivul pt care aceste carduri nu functioneaza conform specificatiilor. o sa incerc cu rez in baza tranzistorului, sa vad daca de acolo e problema, cum spune niq_ro.dar intre timp astept si alte pareri, eventual explicatii cu calcule mai exacte (cine se pricepe la partea analogica)

Share this post


Link to post
Share on other sites

Aha , acum inteleg . Schema cu operational si tranzistor , postata de tine , este schema clasica de stabilizator de tensiune . Nu trebuie nici o rezistenta de limitare , operationalul asigura numai curentul de baza , restul trece prin tranzistor. Ic = beta x Ib . Problema e ca , acest stabilizator nu este foarte performant , rezistenta interna e relativ mare , asa ca la curenti mai mari cade o tensiune importanta pe tranzistor . Circa 3V cad oricum pe orice stabilizator , deci cu 15V alimentarea esti la limita. Cel mai bine ar fi sa ii maresti putin tensiunea de alimentare sau eventual sa-i scazi rezistenta interna schimband tranzistorul cu unul cu factorul beta mare ( Darlington ).

Share this post


Link to post
Share on other sites

Din schema rezulta Uo=(AUi-Vbe)/(1+A) deci daca A.O. e OK rezulta la o A foarte mare neglijand unitatea ca Ui aprox egal Uo. Parearea mea e ca A.O. e iesit din parametrii in ceea ce priveste castigul.

Share this post


Link to post
Share on other sites

Schema prezentata este un clasic generator de tensiune avand impedanta de iesire impedanta de iesire a AO impartita la beta tranzistorului. In mod normal tensiunea din emitor trebuie sa fie cea de la intrarea neinversoare a AO. Verifica in primul rand semnalul de intrare. Ajunge la +12V cat iti trebuie tie?

Share this post


Link to post
Share on other sites

da, ajunge la 12V.ai cuma ceva relatii de calcul pt aceasta schema clasica ? ca eu n-am gasitcred ca am gasit unde incepe problema, dar tot mai are bube:- acest card cu iesiri analogice se leaga cu un cablu panglica de 30 cm la un alt sistem de unde se si alimenteaza cu cu +15, -12V de la o sursa in comutatie de 5A; in panglica (ca la harddisk) sunt 5 fire adiacente pt +15V si 7 fire pt GND, 1 fir pt -12V si semnale RS485 (1 ohm este rez unui fir)- cardul are 16 iesiri analogice, fiecare avand aceasta schema la iesire, iar iesirile se impart in grupuri de cate 4, fiecare are local un opamp LF347, 4 tranzistori BCP55- tranzistorii sunt in capula SOT223, conecatati cu colectorul mare la un plan comun de +15V care are si rol de radiator; exista 4 astfel de plane cu cate 4 tranzistori, conectate intre ele cu trasee de +15V- pe placa exista o sursa cu 78L05 pt partea digitala, care are la intrare un electrolitic de 47uF- nu mai exista nici un alt condensator electrolitic pe placa, decat cond. ceramici de 100nF la integratele digitale- pe iesiri exista un zgomot foarte mare, caderi de tensiune cu valori pk-pk de 16-18V ! acest zgomot creste cu lungimea cablului panglica- am pus la fiecare plan de +15V care are cate 4 tranzistori cate un cond electrolitic de 470uF (intre +15V si GND) si astfel am reusist sa reduc zgomotul de pe iesiri la 5V pk-pk, 11,8V valoarea medie a tensiunii pe releu, ceea ce este acceptabilasta sa fie problema ?inca o chestie: daca una din cele 4 iesiri intr-un grup conectate la aceeasi capsula LF347 cu 4 opamp-uri, nu e pusa pe 12V (adica la intrare pun 0V), iesirea respectiva, desi la intrare are 0V, la iesire, in emitorul tranzistorului apar impulsuri restul de puternice sa comuta releul. daca pun si condesatorul electrolitic de 470uF pe planul de +15V al grupului respectiv de 4 iesiri, atunci dispare acest efect. asta chiar ca nu mi-o pot explica. voi ce parere aveti ?precizez ca am un alt tip de placa, care contine 8 iesiri cu schema de iesire identica cu acest card (cea postata), si tot pe aceeasi placa cu partea analogica este si sursa de alimentare in comutate cu +15V, distanta intre partea analogica si sursa este de 11 cm. desi nici pe aceasta placa nu exista condensatori electrolitici pe bara de alimentare de +15V si masa, decat condesatorul de iesire al sursei, langa sursa, aceasta placa se comporta normal si nu are zgomote la iesire. cu toate cele 8 relee conectate si actionate, tensiuea pe releu este de 11.8V si nici nu apare problema comutarii iesirilor care sunt OFF (care au 0V la intrare), deci nu cred ca schema in sine este gresita.

Share this post


Link to post
Share on other sites

Schema nu e gresita , ori are specificatii mai optimiste fata de realitate ( oricum esti aproape de limita maxima ) , ori sunt probleme de comanda sau alimentare . E foarte mult 1ohm pentru 30cm de cablu . S-ar putea sa fie contacte imperfecte la mufe. Sursa are zgomot inainte de panglica ? S-ar putea sa fie si condensatori electrolitici uscati pe placa sursei. In ambele situatii se explica de ce merge mai bine cu condensatorii adaugati de tine.

Share this post


Link to post
Share on other sites

am masurat cablul cu ohmetrul, din mufa in mufa (mufa DB15) si am scazut rez sondei masurata in scurt. oricum 5 fire de 1ohm in paralel, dau 0.2 ohm * 1A = 0.2V caderea de densiune pe cablu, mica fatza de zgomotul pe alimentarea cardului. pe placa cu sursa nu e zgomot mare, acolo e OK.

Share this post


Link to post
Share on other sites

Inseamna ca tot cablul e , altfel cum iti explici ca pe o parte e bine si pe cealalta nu ?. Daca sunt probleme de contact si rezistenta e prea mare in gol , in consum poate fi si mai mare si e variabila. Pune o sarma in paralel cu el ca sa te convingi.

Share this post


Link to post
Share on other sites

Mi se pare clar care este problema: AI OSCILATII!! Chiar am vrut sa te intreb de la prima interventie daca ai verificat sa nu ai asa ceva. Deci: fii foarte atent la bucle de masa. Pleaca de la conectorul in care se infige cablul panglica si analizeaza. Fii atent ca masa celor patru blocuri sa se adune fix in conector si nu undeva pe parcurs. C-urile de 100n sunt pentru a taia eventualele tendinte de oscilatie

Share this post


Link to post
Share on other sites

Pai ce relatii de calcul sa-ti dau? AO are reactie totala, nu exista atenuare pe bucla (atunci ar fi amplificat cu raportul de atenuare), ce sa mai o lungim, de la intrare si pana la sarcina (emitorul tranzistorului) este practic un repetor.Daca vrei mai mult cauta pe internet "bucle de reactie" sau gasesti foarte frumos explicat in "biblia" electronistilor: "Amplificatoare operationale - analiza si proiectare" (acum nu imi aduc aminte autorii, USA oricum)

Share this post


Link to post
Share on other sites

unde am oscilatii ? adica unde sa masor asta si cum ? placa e dublustrat si are plan de masa pe partea de jos. conectorul DB15 are 5 fire pt +15V si 7 fire pt GND. Fac acum un cablu cu fire groase (1.5mm) si le lipesc cu cositor la ambele mufe, sa elimin cauza asta. va dau de stire ce am masurat. ideea e ca cel care a facut placa (a plecat din tara) zice ca el a testat-o si nu ar fi normal sa apara aceasta problema, adica nu ar fi necesari cond electrolitici care i-am pus eu. mai fac niste teste azi si o sa pun si poze cu semnalul pe osciloscop.multumesc de interes.

Share this post


Link to post
Share on other sites

Daca ai osciloscop te-ai scos (e de baza). In primul rand verifici tensiunea de alimentare fata de masa, atat +15V cat si -12V. Apoi verifici semnalul de intrare tot fata de masa, desi ma indoiesc, dar nu se stie. Intai iei masa de la conector si apoi, eventual masa la releu. Succes

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.