Jump to content
ELFORUM - Forumul Electronistilor
adrian82

ATMEGA FUSEBIT DOCTOR

Recommended Posts

Sper sa va vina in ajutor sa deblocati atmega 8...88...168...at90s2313...attiny2313...mega 16/32/644.Convertiti in hexa pentru a incarca atmega 8.Eu din cauza ca nici unu dintre voi nu mi-ati spus cel putin cum sa-mi rezolv problema legata de acel frecventmetru si mi-am blocat attiny2313 am fost nevoit sa caut pe net orice cum se deblocheaza cum se seteaza etc .Nu sunt programator sunt un mic eletronist care imi doresc sa am scule cu ce sa ma ajut .

Share this post


Link to post
Share on other sites

Nu crezi ca ar fi fost mai corect sa pui legatura la situl autorului, unde e explicat bine proiectul, are si poze si alte cele in plus?

Am incercat eu sa-l postez, am fost sters din nus` ce cauze.... cu toate astea e un subiect bun si de real folos(proiectul) pentru noi acestia mai "prosti" (cum zice Danzup intru-n topic), se poat vedea discutiile din alte topicuri despre acest "deblocator", sper sa nu fie si acesta sters.

Share this post


Link to post
Share on other sites

Nu crezi ca ar fi fost mai corect sa pui legatura la situl autorului, unde e explicat bine proiectul, are si poze si alte cele in plus?http://diy.elektroda.eu/atmega-fusebit-doctor-hvpp/

scuze e bine venit sper sa nu mai avem probleme am vazut pe alt topic ca ai pus situl.eu am vrut sa fie un topic pt asa ceva fiindca am cautat si abia am gasit.bafta.

Share this post


Link to post
Share on other sites

De ieri seara m-am apucat sa fac montajul pentru resetare microcontrolere , azi l-am terminat si am incarcat softul ultima versiune 7 pe un atmega 8l-8pu ceasul l-am lasat la 1Mhz .Am cuplat atmega 9 la montaj l-am alimentat evident prin stabilizare 12 cu 7812 si dupa aceea 7805 iar ledul rosu sta aprins e normal ? Cand apas start (reset) se stinge ledul rosu iar cel verde palpaie cateva secunde dupa aceea se aprinde ledul rosu si ramane aprins e normal ?Vreau sa resetez fusebiti la attiny2313 :( o trebui sa maresc frecventa la atmega8 pana la 8Mhz rc intern ? astept sugesti pareri .M-a mancat in fund ieri sa umblu cu progisp si am setat la attyni2313 highValue DF si LowValue 4D pentru a rula cu un quatz de 4mhz exterior .Dupa ce am modificat fusebiti si i-am dat sa memoreze s-a blocat nu a mai citit.Oricum daca nu-l reusesc sal resetez cumpar altu.Sunt dezamagit :(.

Share this post


Link to post
Share on other sites

De ieri seara m-am apucat sa fac montajul pentru resetare microcontrolere , azi l-am terminat si am incarcat softul ultima versiune 7 pe un atmega 8l-8pu ceasul l-am lasat la 1Mhz .Am cuplat atmega 9 la montaj l-am alimentat evident prin stabilizare 12 cu 7812 si dupa aceea 7805 iar ledul rosu sta aprins e normal ? Cand apas start (reset) se stinge ledul rosu iar cel verde palpaie cateva secunde dupa aceea se aprinde ledul rosu si ramane aprins e normal ?Vreau sa resetez fusebiti la attiny2313 :( o trebui sa maresc frecventa la atmega8 pana la 8Mhz rc intern ? astept sugesti pareri .M-a mancat in fund ieri sa umblu cu progisp si am setat la attyni2313 highValue DF si LowValue 4D pentru a rula cu un quatz de 4mhz exterior .Dupa ce am modificat fusebiti si i-am dat sa memoreze s-a blocat nu a mai citit.Oricum daca nu-l reusesc sal resetez cumpar altu.Sunt dezamagit :(.

Tot 1Mhz am si eu la al meu, adica default. Attiny2313 am deblocat eu si merge. Becul rosu arata ca resetarea nu a reusit, trebuie sa se aprinda verde pentru confirmare resetare. Ce cablaj ai facut?Eu folosesc SinaProg, e mult mai "prietenos", vede Mc-ul si setarile implicite cu comanda serch.

Share this post


Link to post
Share on other sites

Gata si eu azi l-am rezolvat pe attiny2313 ,aveam firele la tranzistori puse invers si de aceea imi sta ledul rosu aprins indiferent de comanda sta aprins deci si specifica ca e o problema de conexiune la tranzistori , de graba si nervii m-a facut sa nu mai trag cu ochiul la schema dar azi am reverificat totul la rece am modificat firele intre ele am inscris softul pe atmega8L-8PU cu ultima versiune la 1Mhz l-am cuplat in montaj .In final am alimentat montajul s-a aprins verde :101 am apasat pe start si ala a fost dpa aceea l-am verificat cu ponyprog ultima versiune si fusebiti au fost adusi la parametrii de fabrica si anume 8Mhz default value adica in rc 8mhz.Sper pe viitor sa ajute si pe alti colegi care intampina probleme.

Share this post


Link to post
Share on other sites

Poate ajuta si schema/softul din atasament. Eu nu l-am folosit (inca :) ) !

Share this post


Link to post
Share on other sites
Guest alinclaudiu

am rezolvat si eu un attiny2313 cu ATMEGA FUSEBIT DOCTOR

Share this post


Link to post
Share on other sites

Am constuit si eu un fusebit doctor dupa documentatia de aici: http://diy.elektroda.eu/atmega-fusebit-doctor-hvpp/Nu am avut ATMEGA 8 asa ca am folosit un atmega 168 cu hex-ul furnizat in ultima arhiva de update (update10-20.04.2011 - atmega_fusebit_doctor_2.10_m168.hex).La pornire palpaie de cateva ori led-ul verde si apoi se aprinde si ramane aprins cel rosu, astaatat cu soclurile goale cat si cu un ATMEGA "bolnav" sau ok in soclu corespunzator.Am realizat si conexiunea cu terminalul din Windows si acolo am observat ca nu sunt detectate cip-urile tinta:=== Asta apare atunci cand soclurile sunt goale (doar cu cip-ul "doctor") ===

WelcomeAVR Atmega fusebit doctor (HVPP+HVSP) version 2.09http://diy.elektroda.eu/atmega-fusebit-doctor-hvppUsage in commercial/profit purposes not allowedfor firmware updates: twitter.com/manekinenHVPP MODEInit programming... DONERead signature... 00 01 00 - FAIL!Trying T2313 pinout..00 01 00 - FAIL!No chip in socket or chip does not respondingPlease try again...Thank You

Daca introduc un cip tinta in unul din socluri, indiferent daca acesta este ok sau nu, mesajul este asemanator cu mici diferente la read signature...Am incercat un ATMEGA88 si un ATTINY2312 pe care nu le pot citi cu programatorul ISP, precum si un ATMEGA16 si un ATMEGA32 noi, nefolosite pana cum.Am reverificat toate traseele, functionarea tranzistorilor care comuta tensiunile de +12V si +5V sitotul pare ok, nu am gasit probleme...In acest moment mi-ar prinde bine o idee .... ce credeti ca ar mai trebui sa verific ?Multumesc!

Share this post


Link to post
Share on other sites

nu pune nimeni ceva poze sa vedem si noila ei pe site zice sa verifici trecerile de sub atmega 16 alea 6 sa nu faca scurt intre ele

Share this post


Link to post
Share on other sites

Am realizat si eu, fortat de imprejurari, un Atmega Fusebit Doctor dupa proiectul de aici: http://diy.elektroda.eu/atmega-fusebit- ... p/?lang=en :da

Am folosit un Atmega8 in care am "varsat" hexul de pe site si am reusit sa "resuscitez" cu el momentan, un Attiny13 si un Atmega8 blocate. :aplauze

Foarte util daca se lucreaza cu microcontrollere din seria Atmel, mai ales daca esti incepator si nu le "vezi" cu ele, ai sanse mai mari de a le bloca, deci NU strica sa "fie" in dotare. :rade:

Am sa revin cu ceva poze cat de curand.

Share this post


Link to post
Share on other sites

Si ceva poze cu Deblocatorul meu. :daNu am montat soclul de 40 pini si de 20 pini, nu am momentan.post-17385-139829306473_thumb.jpgpost-17385-139829306493_thumb.jpgpost-17385-139829306514_thumb.jpgpost-17385-139829306534_thumb.jpgSi acum "adaptorul" meu :rade: pentru Attiny 13, realizat pe "fuga" din fire si un soclu, nu am mai stat sa fac un cablaj, mai tarziu am sa fac cele 2 placute adaptoare pentru deblocator.post-17385-139829306565_thumb.jpg

Share this post


Link to post
Share on other sites

... continuare Atasez o arhiva care contine cablajul la sc 1:1, redesenat de mine si folderul cu Firmware, pentru diferite tipuri de Atmega. :da[attachment=0]Atmega Fusebits Doctor.rar[/attachment]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.