Jump to content
ELFORUM - Forumul electronistilor

Probleme cu axa z


Guest ryan25

Recommended Posts

Guest ryan25

Salutare sunt incepator in domeniul cnc si mi-am construit singur un router pentru acasa.Problema pentru care apelez la voi este ca pe axa z am un motor nema 1.3Nm si cand lucrez pe diferite inaltimi freza coboara cam cu 5mm fata de cotele desenului (pierde pasi) pe distanta de 5cm.

 

Cand am schimbat motorul cu unu de 1.5Nm se intampla exact invers se ridica cam cu 4mm fata de cotele desenului (castiga pasi) pe distanta de 5cm.Mentionez ca motorul de pe axa z de 1.3Nm l-am schimbat cu cel de pe axa x de 1.5Nm modificand doar pini din soft-ul mach 3 de la config.

 

Poate sa ma lamureasca cineva cu aceasta problema? :nas:

Link to comment
Share on other sites

Probabil e diferenta constructiva, numarul de pasi pe rotatie (trebuie sa fie notat pe eticheta motorului).1- Fara sa fie alimentat sistemul, invarte manual si fa o rotatie completa a motorului axei respective. 2- Masoara deplasarea obtinuta. 3- Imparte numarul de pasi de pe eticheta motorului, la cati milimetri ai obtinut prin deplasarea la operatiunea precedenta. Acum ai numarul de pasi/mm, valoare ce trebuie sa o setezi in program pentru axa respectiva. Este o metoda "babeasca"... dar, pentru incepatori e suficienta. Poate o sa mai ai nevoie de ceva ajustari, e doar un punct de plecare.

Link to comment
Share on other sites

Guest ryan25

Am folosit setarile automate pentru pasi/mm din mach3 pe toate axele si rezultatele sunt bune adica daca dau 10mm axele se deplaseaza 10mm. problema apare doar la un numar repetat de miscari sus-jos ale axei z atunci apare pierderea de pasiam sa fac mai multe probe cu modificare ale unor parametri poate aflu de unde e sursa problemei

Link to comment
Share on other sites

Motorul este nema 23 ...cred ... in general astea au 1.8 grade pe pas / 200 pasi /rotatie . Daca ai facut testele si se deplaseaza corect , inseamna ca setarile din Mach sunt bune ... verifica daca piulita care tine surubul de pe Z nu s-a slabit cumva ( joc axial ) . Verifica daca setarile driverului pe Z sunt corecte ( microstep daca e , curent , voltaj ) . Ce pas are surubul ? Ce setare ai in mach pentru Z ( units / mm , viteza , acceleratie , etc ) ? Motorul de pe Z e suficient de puternic sa duca greutatea axei ? Driverul e " trompeta " ? Bafta .

Link to comment
Share on other sites

Guest ryan25

Motorul este nema 23 ...cred ... in general astea au 1.8 grade pe pas / 200 pasi /rotatie . Daca ai facut testele si se deplaseaza corect , inseamna ca setarile din Mach sunt bune ... verifica daca piulita care tine surubul de pe Z nu s-a slabit cumva ( joc axial ) . Verifica daca setarile driverului pe Z sunt corecte ( microstep daca e , curent , voltaj ) . Ce pas are surubul ? Ce setare ai in mach pentru Z ( units / mm , viteza , acceleratie , etc ) ? Motorul de pe Z e suficient de puternic sa duca greutatea axei ? Driverul e " trompeta " ? Bafta .

Salut,surubul pentru z este de 12x3 iar driverul este luat de pe hi-end.Setarile sunt :units/mm-66.66,viteza 199,98 ,acceleratie 300 ,step pulse 18 ,step dir 9.Acum folosesc micropasi la drivere dar cum am spus mai sus daca schimb motorul de 1.3Nm cu unu de 1.5Nm "castig" pasi in loc sa-i pierd.Am facut un test de taiat in gol cu motorul de 1,5Nm si mergea bine doar in sarcina castiga pasi.E posibil ca axa z sa fie influentata de celelalte axe in sarcina?
Link to comment
Share on other sites

  • 4 weeks later...
  • 1 year later...
Guest Loredana5

Ma bucur ca v-am gasit. Si eu am aceeasi problema, anume Mach3, iar axele o iau razna, respectiv Z-ul urca iar X-ul si Y-ul au si ele abateri majore. Axele sunt setate corespunzator din Mach3, controller-ul nu este unul de top. As vrea sa stiu ce solutie ati gasit dvs. si ce vrea sa insemne ecranarea cablajelor. Va multumesc.

Link to comment
Share on other sites

  • Administratori

e posibil sa ai mach3 cu licenta proasta sau crackuit, eu o noapte intreaga m-am chinui odata pana sa-mi dau seama ca respectivul avea o licenta luata de pe net care schimba setarile

Link to comment
Share on other sites

Guest Loredana5

M-ar interesa cum a rezolvat problema Ryan 25, as incerca si eu aceasi rezolvare si daca nu merge nici asa as merge mai departe, nu stiu daca Mach 3 schimba setarile in mers, cum pot verifica asta? Cert este ca daca fac o fotografie axele fug de capul lor iar daca am un desen ca o floare de ex adica numai lini axa z o ia in sus.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines