Jump to content
ELFORUM - Forumul electronistilor
Guest sandigol

probleme atmega8 + LCD

Recommended Posts

Guest sandigol

Am de facut pentru licenta un montaj cu un atmega 8 si un LCD pe care sa imi afiseze diferite mesaje.Am realizat montajul am conectat toate firele ca in schema electrica ,am programat microcontrolerul insa nici un rezultat.Pe Lcd imi apare doar prima linie ca si cand ar fi doar alimentat.In soft am setat bine pinii pt microcontroler pentru ca pe placa de test se aprind ledurile corespunzatoare pinilor setati.In montajul pe care l-am facut am incercat sa masor daca pe pinii pe care i-am setat la uC imi da tensiune insa tensiunea este 0.Daca ma puteti ajuta cu un sfat pt ca am disperat cu toate incercarile?

Link to comment
Share on other sites

Guest sandigol

am rezolvat acea problema cu lcd-ul.solutia era sa schimb o setare la programul placii de achizitie mai precis sa setez folosirea oscilatorului extern.....

Link to comment
Share on other sites

Am si eu cam aceasi problema, e prima data cind incerc sa leg un LCD la Uc si bineinteles ca nu merge, asa ca va rog frumos sa va uitati un pic peste schema si soft si sa-mi spuneti unde e greseala.LCD-ul e 8X2.[attachment=0]lcd 8x2.jpg[/attachment]$regfile = "m8def.dat"$crystal = 4000000$baud = 9600Config Lcd = 16 * 2Config Lcdpin = Pin , Db4 = Portb.0 , Db5 = Portb.1 , Db6 = Portb.2 , Db7 = Portb.3 , E = Portb.4 , Rs = Portb.5ClsLcd "Salut"Wait 5end

Link to comment
Share on other sites

Programul e bun trebuie sa mearga daca e ca in schema !ai pus semireglabilul de stralucire cu cursorul la masa ?

Deci programul e bun, schema e buna ce o avea de nu merge...Semireglabilul e pus si merge, nu e cu cursorul la masa ci spre Vo de la LCD. Spun ca merge (contrastul) pentru ca obtin citeodata niste caractere ciudate pe display si asa l-am incercat.Nu stiu ce sa zic, o sa incerc sa fac alt cablaj in care o sa cuprind si un led sa ma asigur ca Uc se incarca si lucreaza corespunzator.
Link to comment
Share on other sites

1. in schema, pinul de reset e legat doar la acel conector, de programare banuiesc, ÎNS? nu il vad legat la Vcc nicaieri, asa cum ar trebui legat printr-o rezistenta, dioda, ceva, ....2. ai setat fusebitii in concordanta cu frecventa de 4MHz ? initial vine setat pe 1MHz....

Link to comment
Share on other sites

1. in schema, pinul de reset e legat doar la acel conector, de programare banuiesc, ÎNS? nu il vad legat la Vcc nicaieri, asa cum ar trebui legat printr-o rezistenta, dioda, ceva, ....2. ai setat fusebitii in concordanta cu frecventa de 4MHz ? initial vine setat pe 1MHz....

1.Intradevar pinul reset nu e legat decit la mufa programare, e musai sal leg prin rezistenta la Vcc? pentru ca la niste attyni cu care am lucrat mai inainte nu l-am legat si a fost in regula asa, dar daca o sa fac alt cablaj o sa-l leg.2. Da fusebitii sint setati corespunzator
Link to comment
Share on other sites

Am refacut cablajul cu modificarile de mai sus si acum functioneaza. Mai departe vreau sa merg spre un Voltmetru/Ampermetu pentru o sursa de alimentare reglabila, stiu ca se gasesc pe net insa eu am un LCD 8x2 la care nu prea gasesc soft. Mai jos pun o poza cu o bucata de schema, va rog sa-mi spuneti daca e corecta, ca si intrari pentru cele doua tensiuni V/A.[attachment=0]Clipboard01.jpg[/attachment]

Link to comment
Share on other sites

Am facut Voltmetru , am folosit un divizor 100k/10k pe intrare insa nu afisaza corect in sensul ca i-mi fluctueaza valoarea afisata rau de tot. Am incercat sa pun un condensator in paralel pe intrarea ADC insa nu prea da rezultat. Aveti idee ce se intimpla?

Link to comment
Share on other sites

Pun si un film cu ce se intimpla, poate asa va dati seama despre ce e vorba.

Intrarea in Uc o fac cu urmatoarea schema:

[attachment=0]Div.jpg[/attachment]

Condensatorul l-am pus de la 1U pina la 100U insa fara efect.

Filmul e facut fara cond.

Cu un aparat de masura valoarea afisata nu fluctueaza.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines