Jump to content
ELFORUM - Forumul electronistilor

Controler motor pas cu pas


Badman

Recommended Posts

  • 4 weeks later...
  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

Guest levis36

sarumana de schema.... dar acum mai am o problema: Respectivele ENA,ENB,ENC (acele jumpere) sunt "senzorii",sau mai bine zis sunt pentru contactele de home?? SI k12(sense 1...4) pentru ce sunt? Stiu ca poate suna destul de prostesc intrebarile mele dar vreau sa incep un cnc si trebuie sa ma documentez bine inaine sa incep....

ai reusit cu aceasta schema? merge? cam asa ceva vreau sa fac si eu, are vreo importanta daca folosesc motoare mai mici ex 1A pentru inceput?
Link to comment
  • 2 months later...
Guest dzuby2005

salut am si eu 3 controllere(prima poza)..problema e in felul urmator..am incercat sa folosesc mach3 si emc2 ca sa pornesc motoarele..si surpriza..portul paralel imi da 1 logic(pe toti pinii de intrare adica step si dir,pinii2,3,4,5,6,7) am incercat sa definesc pinii dar fara succes adica i-am definit..dar imi face acelasi lucru...cum sa fac sa imi mearga este vreo setare speciala din windows sau linux??....inca o intrebare..este posibil sa il ard daca folosesc ca sursa de alimentare o sursa de calculator???nu de alta dar este mai simplu decat 2 surse facute de mine..care nu sunt prea precise... :jytuiyu

Link to comment
  • Administratori

Sa inteleg ca ai 1 indiferent de starea setarilor ?In mach3 intri la Port and pins si de acolo setezi pinii. Vezi sa nu ai versiune cu crack pentru ca aia nu merge binemerge si cu sursa de calculator dar vezi ca e zgomotoasa si L297 e foarte sensibil, pentru orice eventualitate pune pe fiecare intrare(step si dir) cate o rezistenta de 10K la masa

Link to comment
Guest dzuby2005

Sa inteleg ca ai 1 indiferent de starea setarilor ?In mach3 intri la Port and pins si de acolo setezi pinii. Vezi sa nu ai versiune cu crack pentru ca aia nu merge binemerge si cu sursa de calculator dar vezi ca e zgomotoasa si L297 e foarte sensibil, pentru orice eventualitate pune pe fiecare intrare(step si dir) cate o rezistenta de 10K la masa

dap am 1 indiferent de setare....mach3 ca mach3 dar si emc2 care teoretic nu ar trebuii sa faca probleme...cat despre bios...nush daca portul este epp cinstit nici nush unde in bios sa ma uit...dar am avut un prg facut in c++ builder si mergea destul de bine cu portul paralel era pt un circuit cu niste leduri care se aprindeau la un interval de timp..deci portul ar trebuii sa mearga cred ca nu fac eu ceva bine.....sau nu e buna versiunea de mach3...poate emc2 nu merge pt ca il rulez de pe virtual machine2007...sau e ceva din xp sp3...nu stiu..mai incerc...trebuie sa iasa...incerc si cu kcam poate asta merge..dar am versiune trial..
Link to comment
Guest dzuby2005

poate cineva sa imi dea si mie niste printscreen-uri cu setarile pt pini si ce mai trebuie??nu de alta dar cred ca fac eu ceva gresit....

Link to comment
Guest dzuby2005

m-am chinuit ceva dar am reusit..am instalat ubuntu pe calc nu l-am mai folosit prin virtual machine pt ca nu ii da voie windowsul sa foloseasca portul paralel(de ce nu stiu) mach3 tot nu merge decat daca este pornit kcam..oricum important e ca pot sa folosec ori emc2 ori kcam..multumesc mult de ajutor :aplauze :aplauze :aplauze

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines