Jump to content
ELFORUM - Forumul electronistilor
cristi7521

Citire Atmega324 cu ICE Debugger

Recommended Posts

Buna ziua,

 

Va rog sa ma ajutati pentru rezolvarea urmatoarei probleme.

Doresc sa ma conectez prin Jtag la un Atmega324 programat (aflat pe o placa) din Atmel Studio dar nu stiu cum sa verific daca sunt probleme cu conexiunea.

Daca selectez Device Programming, Atmega324pb, JTAG si dau read imi apare eroarea 

No JTAG devices detected. Debugger command Activate physical failed.

Unable to enter programming mode. Verify device selection, interface settings, target power, security bit, and connections to the target device.

Pe debugger sunt aprinse ledurile rosu si galben.

Daca microcontrollerul este blocat din bitii de lock mai permite detectarea (citirea Device signature)?

Ce pot sa mai verific?

Este prima data cand lucrez cu acest debugger si Atmel Studio, ma intereseaza doar sa verific ca este buna conexiunea (pentru programare si debug)

 

Multumesc

 

 

 

Link to post
Share on other sites

Este vorba cumva de programatorul Atmel-ICE original? In caz afirmativ, ar trebui sa recunoasca microcontroller-ul, insa daca acesta nu este alimentat (ceea ce cred ca s-a intanplat) vei obtine un mesaj de eroare de genul celui pe care l-ai primit.

Link to post
Share on other sites

Este programatorul original.

https://ro.farnell.com/microchip/atatmel-ice-basic/debugger-atmel-arm-avr-basic-kit/dp/2407172?gclid=CjwKCAjwnef6BRAgEiwAgv8mQel6XR2a-thGdgVco4onCpmv4osNPbIIFjrhtP1g5-gw3r1yjK0qshoCgIkQAvD_BwE&gross_price=true&mckv=eS8MpZqq_dc|pcrid|445379574462|&CMP=KNC-GRO-GEN-SHOPPING

Pe pcb este un alt conector si a trebuit sa fac un cablu intermediar.

Cand alimentez placa pe care se afla microcontrollerul se aprinde ledul galben de la programator.

Stie cineva configuratia (verificata) a pinilor din conectorul de pe Atmel ICE?

Eu am presupus ca sunt ca mai jos. In manualul programatorului este dat tabelul cu functiile pinilor, dar nu scrie din ce parte incepe numaratoarea

Au mai patit si altii

https://www.avrfreaks.net/forum/problems-atmel-ice-jtag-and-atmega16a

image.thumb.png.40a63b0ca175017e8579566fa19069dd.png

Obs: Imi detecteaza tensiunea de pe pcb de 5V, daca nu alimentez pcb-ul spune ca nu detecteaza target voltage

Edited by cristi7521
Repetare test
Link to post
Share on other sites

Multumesc pentru raspunsuri.

M-am conectat pe ISP si detectez controllerul.

Bitul LOCKBIT.LB este setat pe "Further programming and verification disabled"

Bitul HIGH.JTAGEN nu este bifat.

 

Inseamna ca este blocat si JTAG este dezactivat?

Mai am vreo optiune in afara de a-l sterge?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines