Jump to content
ELFORUM - Forumul Electronistilor
Sign in to follow this  
Lilith

Upload error

Recommended Posts

Buna ziua, cand incerc sa incarc programul din IDE primesc aceasta eroare:

Sketch uses 726 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\calin\AppData\Local\Temp\arduino_build_254713/sketch_may20a.ino.hex:i 

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : Arduino
         Description     : Arduino
         Hardware Version: 3
         Firmware Version: 4.4
         Vtarget         : 0.3 V
         Varef           : 0.3 V
         Oscillator      : 28.800 kHz
         SCK period      : 3.3 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f (probably m328p)
avrdude: reading input file "C:\Users\calin\AppData\Local\Temp\arduino_build_254713/sketch_may20a.ino.hex"
avrdude: writing flash (726 bytes):

Writing | ########avrdude: stk500_recv(): programmer is not responding
########avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

 

Stie cineva de ce si care ar fi solutia ?

Share this post


Link to post
Share on other sites

Programmer not responding. 

 

Ai instalat driverul FTDI sau CH340 sau de care ai tu acolo? 

 

Daca da, ai ales bine COM3? Poti vedea in Device Manager pe care COM este detectat Arduino. 

Share this post


Link to post
Share on other sites

Pune captura de ecran din Device Manager cu Arduino conectat ca sa vad ce vede Windows ca porturi COM.

Share this post


Link to post
Share on other sites

De multe ori inchiderea programului Arduino IDE  si repornirea lui, urmat de un reset la Arduino UNO ...rezolva problema.

 

1090909888_oldbootloader.thumb.jpg.6cea261ea8b505ffba22598d1efb6fd5.jpg

Edited by sebip

Share this post


Link to post
Share on other sites

Mai poate fi si setarea de baudrate ale usb-serial , poate fi si un sistem Arduino care a avut probleme si care ar necesita rescrierea bootloaderului

Incercati si in alt port usb

Imaginea nu contine setarile care trebuie realizate...ci doar locul unde se pot modifica !!!

370627781_oldbootloader.thumb.jpg.9c1a3e40783c99f111a9c1a69f69ee57.jpg

Edited by sebip

Share this post


Link to post
Share on other sites

Nu sunt in fata calculatorului, dar poti utiliza Terminal ca sa verifici comunicatia.

 

E bine ce vezi in Device Manager.

Share this post


Link to post
Share on other sites

Salut,

 

Ca si ceilalti colegi, suspectez ca e o problema de comunicatie cu bootloaderul, dar asta poate sa aiba multiple cauze. De la viteza incorecta pe seriala procesorului pana la bootloader corupt sau inexistent, fusebiti setati incorect sau procesor defect.

 

Cred ca e util de stiut putina istorie a placii. Este noua luata din magazin sau ai primit-o de la cineva sub forma "ia-o si fugi" ? A functionat inainte si deodata nu mai merge sau acum e prima data cand incerci sa "vorbesti" cu placa? Daca e primita si nu i se cunoaste istoria, pot fi multe, dar in acelasi timp sansele sunt mari sa fie rezolvabile, dar de catre cineva care stie cum sa o depaneze si are si sculele necesare.

 

Cirip

 

 

Edited by cirip

Share this post


Link to post
Share on other sites
49 minutes ago, cirip said:

Salut,

 

Ca si ceilalti colegi, suspectez ca e o problema de comunicatie cu bootloaderul, dar asta poate sa aiba multiple cauze. De la viteza incorecta pe seriala procesorului pana la bootloader corupt sau inexistent, fusebiti setati incorect sau procesor defect.

 

Cred ca e util de stiut putina istorie a placii. Este noua luata din magazin sau ai primit-o de la cineva sub forma "ia-o si fugi" ? A functionat inainte si deodata nu mai merge sau acum e prima data cand incerci sa "vorbesti" cu placa? Daca e primita si nu i se cunoaste istoria, pot fi multe, dar in acelasi timp sansele sunt mari sa fie rezolvabile, dar de catre cineva care stie cum sa o depaneze si are si sculele necesare.

 

Cirip

 

 

Placa e comandata de pe xab3 si am primit-o ieri, iar azi am incercat sa o folosesc pentru a aprinde un led si a genera un sunet cu un buzzer, dar fara succes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.