Jump to content
ELFORUM - Forumul electronistilor
Freaka666

Crossover activ pt sistem 2.1 pe 2 cai

Recommended Posts

Buna seara, am nevoie de unpic de ajutor pentru schema atasata.

Am nevoie de un crossover activ pe 2 cai pentru viitorul sistem 2.1 sau 4.1 (inca nu sunt sigur), dupa multe sapaturi pe net am desenat schema respectiva dar tot am niste neclaritati si vreau sa ma apuc de constructie cat mai repede.

Crossoverul o sa trimita semnal la amplificatorul de woofer si la cele pt sateliti (ma multe blocuri mono).

Am ales TL072 pt ca exista mai multe alternetive cu perfomante mult mai bune si au acelasi pinout.

Asadar, sa trec la problema, nu am pus phase switch. Nu inteleg in ce conditii se shiftuie faza, am citit ca faza nu are nici o treaba cu wooferul dacat daca e pe incinta cu mai multe cai(care oricum sunt separate in incinta) desi am vazut multe woofere cu switch-ul de faza.

Va multumesc.

post-258111-0-87805600-1491600301_thumb.jpg

Link to comment
Share on other sites

Defazarea se produce la undele sonore, in functie de amplasarea subwooferului fata de celelalte difuzoare. Subwooferele mai cu "pedigree" au posibilitate de reglaj al fezei continu de la 0-180 grade, cele mai simple doat un comutator.

Link to comment
Share on other sites

Pai in schema actuala observ ca am ~150 grade defazare... semnalul asta pot sa il "rotesc" cu bufferul de pe iesire sa trec semnalul pe intrarea inversoare desi face unpic de zgomot in plus fata de intrarea neinversoare.

Si e normal sa am asa forma ciudata la semnalul de iesire cand colecteaza joasele de pe ambele canale?

post-258111-0-21619500-1491684910_thumb.jpg

post-258111-0-64143600-1491684910_thumb.jpg

post-258111-0-05136700-1491684911_thumb.jpg

Link to comment
Share on other sites

Problema persista... am schimbat mai multe valori la toti rezistorii din jurul la U3A si U6A si e acelasi lucru... daca reduc gain-ul nu pe o parte si il cresc pe alta ajung la acelasi lucru :( poate chiar mai rau ca am schimbat bufferul de iesire la subwoofer si e pe intrarea inversoare sa fie in faza cu satelitii si pe inversoare face distorsiuni si mult noise care creste urat de tot cu gain mai mare.

O sa fac un cablaj de proba si vad cum se comporta pe muzica :/

Edited by Freaka666
Link to comment
Share on other sites

In serie cu R11 si R12? am incercat si e la fel... doar ca imi taie din putere si cand cresc gain-ul ajung tot acolo... cred ca e un cerc vicios acolo si cred ca nu are rost sa imi mai bat capul cu chestia aia.

 

Am facut cablajul si a mers din prima. L-am cam compactat prea tare ca abia au intrat mufele :))) Pe spate am pus strapuri(pe + si pe -) cu rezistori smd de 0R dar bineinteles ca am uitat sa ii comand cand am facut comanda, deocamdata am pus pini sa fac legaturile.

 

Are totusi cateva mici probleme cred, ceva noise destul de slabut cand e vol max. Cred ca provine si din cabluri ca am pus de proba cabluri de cacao fara ecranaj si nici alimentarea nu e stabilizata 2x12Vcc, integratele TL072 am inteles ca sunt destul de zgomotoase dar am zis sa fac de proba sa vad ce iese.Este posibil sa am si ceva bucle de masa desi am intrerupt masa in cateva locuri sa nu faca bucle pe cat posibil... ca e single sided pcb.

 

Pe intrare am pus pot logaritmic de 100k sa controlez volumul cu un singur pot dublu, pt a evita 5x poturi. Cu semnal din calculator scoate destul de bine dar din telefon e praf semnalul de iesire, cum as putea sa cresc volumul? Ajustez R1 si R6? Sau cresc gain-ul din bufferele de iesire.

 

Cam asa arata minunea:)))

 

qKeWu2K.jpg

 

Am75Iqa.jpg

 

1dG1c4h.jpg

Link to comment
Share on other sites

Deci...eu personal am lucrat/lucrez cu filtre active si cu tot ce m-am jucat pana acum, ceva noise tot va fi in special la volum maxim´. Daca acel noise e separator atunci incearca si alt op-amp cu noise mai scazut....si desigur ajustarile care le-ai evidentiat chiar tu, ar trebui facute! Indiferent de astea, daca iti place tie ce a iesit si cum se aude atunci foarte bine,daca nu atuci eu tot iti spun felicitari pentru reusita!

Din telefon, semnalul tot praf va fi indiferent ce ai face, iar pentru asta ar fi necesar un preamp sau un buffer suplimentar. Totusi vezi ca telefoanele din ziua de azi au 15.000 de aplicati....poate e din aplicatie, sau poate ai gain sa-i dai din aplicatia audio de pe telefon si te scapi ieftin cu asta!

Totusi, eu pe la buffere de intrare am folosit pentru R1 si R6 (conform schemei tale) am folosit rezistori de 10K dar asta nu credca te va ajuta cel putin nu mult.

O alta abordare ar fi sa cresti factorul de amplificare prin introducerea de feedback rezistor intre pinii intrarii inversoare la U1 si U2....practic ceva cum ai facut cu bufferele de iesire, dar dezavantajul este ca atunci cand vei baga semnal de pe, PC, atunci noise-ul se va mari, dar cu telefonul va functiona ok!

Link to comment
Share on other sites

Da, va multumesc. Testul l-am facut pe sistemul audio 2.1 care e pocnitoare... si dupa ce am postat mi-am dat seama ca ala are tona de galagie din nastere(si sa fiu sincer parca are mult mai mult noise direct din pc in sistem decat daca e prin filtre)... plus fire aiurea, mai mult am fost curios daca functioneaza si cum functioneaza. Sunt destul de multumit deocamdata dar trebuie sa il testez cum trebuie. pe amplif dedicat si fara asa multe improvizatii.

Cel mai probabil o sa fac un buffer suplimentar pe intrare cu comutator daca pun semnal din telefon, cum a-ti sugerat. Nu cred ca are rost sa complic treburile pt telefon care sincer nu stiu cat timp o sa cante de pe telefon:))) probabil 2-3 ori pe an:))

Si cand termin tot sistemul probabil o sa mai maresc unpic factorii de amplificare in functie de cat duce tot sistemul dar sa nu distorsioneze.

Si la opamps ma gandeam la LM4562 au si acelasi pinout si performante muuult mai bune decat TL072.

 

Mai ramane sa ii fac si modulul de alimentare care sincer nu stiu daca sa il fac stabilizat sau nu, aveti vreo sugestie?

Am un traf de 2x9vca din ceva cd player sony are vreo 10-15w cred, cu el am testat cu o punte simetrica din aia default :)) si redresat are undeva la 2x12.5vcc. Daca fac o alimentare cu diode rapide si conds de decuplare pe toate diodele mai e nevoie de stabilizare? Sau sa pun totusi LM317-337 sa fie cat mai liniara alimentarea?

Link to comment
Share on other sites

Din propria experienta, daca op-ampul nu este alimentat la 2x15V posibil sa "mamance" din inalte, cel putin mie asa mi sa intamplat si cand i-am dat 15v inaltele au devenit mai "fine" si nu asa galagioase!

Stabilizarea are rolul ei, e mai indicat sa existe! Cu 7815 si 7915 ai sa faci treaba buna sigur dar sa ii pui pentru orice eventualitate pe ceva radiator , desigur izolati! Despre alimentatare....as recomanda un 2 x 13-14V si sa faci o redresare cu 2 punti redresoare si filtraj undeva la 2200uf, daca ai mai mult e si mai bine. Pe diodele redresoare din punte un snubber (rezistor+condensator) nu ar strica, un sinplu condensator nu stiu daca ar avea un impact atat de mare. Un filtru CRC sau CLC nu ar strica pe alimentare dar asta este mai mult optional. De ce am recomandat 2 x 14v? este ca dupa redresare si filtrare ai 14 x 1,41 = 19,74V si scazand caderea pe diode, daca ai 2 punti 3v daca faci doar cu o punte 1,5V, deci...16,74V respectiv 18,24V, iar pentru 7815 (7915) ai nevoie undeva la 17V pe intrare ca sa ai 15V pe iesire. Puntile redresaoare pot fi de 2A, sau poti face din 1N4001-4007 DACA e vorba doar de montajul asta, deoarece nu ai consum mai mare de 0,5A (exagerat vorbind, ca nu am satat sa calculez exact).

 

Tine minte un lucru, alimentarea, si cum o faci, este la fel de importanta ca si montajul (in unele cazuri chiar mai importanta).

 

Spor la treaba!

Link to comment
Share on other sites

Multumesc! Saptamana viitoare ma apuc de constructii, pana atunci "fac planurile".

Pai TL072 consuma 5mA pe capsula si LM4562 au 10-12mA, oricum tot montajul nu depaseste 100mA in oricare dintre conditii.

 

Am gasit o schema interesanta la care pot sa folosesc transformatorul care il am si poate fi pus pe pcb pt ca are pini laterali. Vreau sa fie cat mai compacte montajele pt ca vreau sa evit prea multe cabluri in incinta la sub.

Pe site-ul de unde am luat-o spunea ca e low noise dar as vrea cateva schimbari gen diodele de redresare D2-D4 sa fie ceva rapide cu low noise, inductori in loc de R1 si R2 si semireglabili in loc la R4 si R6.

Am citit unpic despre filtrele CRC si CLC despre care ati spus si CLC sunt mult mai ok la riplu si la noise decat CRC. Desi un inductor de ex de 0.4mH fara miez e destul de mare si fizic iar cei cu miez se satureaza :/

 

Sarbatori fericite!

 

X9oY1p2.png

Link to comment
Share on other sites

Am descoperit o problema, primele teste au fost facute fara potentiometru.... am reglat volumul din calculator dar acum cand am legat majoritatea chestiilor pt test sa vad cum functioneaza pt ca ma apuc de incinte... probleme adica un brum grav intre aprox 10%-90% volum. La volum foarte mic sub 10% si la "blana" 90%+ nu este brum. Nu am idee de ce, am pus potentiometrul si inainte si dupa condensatorii de intrare si nici un efect.

Aveti vreo idee care este problema?

Link to comment
Share on other sites

Am rezolvat problema brumului... a fost o bucla de masa pe undeva intre crossover si sursa de semnal, dupa ce am legat toate masele de semnal in stea a disparut brumul.

 

Alimentarea nu este ce-a din schema de mai sus, am facut alteva. Data viitoare cand imi mai vin idei de smd o sa ma impusc inainte.

http://imgur.com/bl6zQtU

http://imgur.com/L4nJVtp

 

Totul merge ok cu exceptia basului care este destul de anemic. Deocamdata basul este taiat pe la 200Hz dar il cobor la 140hz numai sa gasesc rezistorii prin jungla de componente si ma gandesc sa pun un bass booster intre U3B si U6A dar nu am idee cati db increase 9-12-15? Si renunt la canalele de "back" pt ca ramane 2.1, ideea de 4.1 s-a dus pt ca face suficienta galagie asa cum este.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines