Jump to content
ELFORUM - Forumul electronistilor

PWM cu 555 de la 0%?


Recommended Posts

Lucrez la un pwm cu 555, schema clasica care comanda un optocuplor si in final un mosfet pus in diagonala unei punti redresoare la 220v ...

Ideea este ca nu prea pot sa il fac sa mearga de la 0, mereu ramane becul aprins foarte putin dar eu as vrea sa mearga de la 0 de la stins complet.

Am verificat si la iesirea din 555 cu un led inseriat cu o rezistenta si nici acesta nu se tinge complet cu potentiometru la minim....

Schema este aceasta, clasica, numai ca la iesirea din 555 am o rezistenta de 1k si un optocuplor ...

 

Posted Image   Posted Image

Edited by mirceacra
Link to comment
  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Nu se poate cu această schemă de la 0. Eventual micșorezi R2 ( dar nu poți prea mult ) sau mărești R1 ca să te apropii mai mult de zero .Problema e că în ambele cazuri vei avea un reglaj destul de abrupt în vecinătatea lui zero . O variantă analoagă ca funcționare dar care permite micșorarea lui R2 mai mult și un factor de umplere simetric este să lași pinul 7 în aer și să muți R2 de la +Vcc la Out ( pin 3) . Oricum , foarte aproape de zero ( adică sub 0,5-1% DC ) nu cred că poți obține stabil . 

Link to comment

Schema standard - generator de rampă și comparator . Și aici însă lucrurile se pot complica dacă vreau să elimin ”cursa moartă” . 

( Adică am 0 la un capăt al potențiometrului , rotesc , am tot 0 . Abia de la un punct începe să crească până la 100% apoi iar am o bucată de cursă moartă până la capătul potențiometrului .)

De obicei însă nu ar trebui să conteze un 0,5%-1%  care se poate obține cu 555 într-o schemă îngrijită.

Link to comment

Îngrijită înseamnă calculul exact al valorilor și , probabil, o anumită experimentare . Schema de la postul #3 o văd abia acum , e varianta de care vorbeam și eu mai sus . Încearc-o , ar trebui să se apropie de zero . Poți să iei ieșirea spre optocuplor tot din pinul 3 și să lași pinul 7 în aer, cum am zis.

 

PS Am citit mai atent primul post și , mai ales, m-am uitat la schema din partea dreaptă. Păi în schema aia , nu numai oscilatorul cu 555 e de vină . MOSFET-ul ăla se blochează destul de lent . Un foarte scurt impuls îl deschide prin optocuplor în schimb blocarea prin 22k este lentă . 

Iar ceea ce spui cu LED-ul e normal, LED-ul este străbătut de curent mare chiar dacă pentru un timp scurt și ochiul îl vede aprins chiar dacă nu percepe pulsația .

Ar trebui văzut cu un osciloscop care este factorul de umplere real - sau cu un multimetru care are această funcție . Se poate vedea , mai puțin precis, și cu un multimetru pus pe CC care va integra impulsurile de la ieșire la ( aproximativ ) valoarea lor medie .

Pentru că altfel s-ar putea să căutăm vinovatul  în  curtea greșită. Până la urmă , s-ar putea ca ambele părți ale schemei să contribuie la problemă . 

Link to comment
  • 2 weeks later...

Din păcate la scheme cu control direct nu poți face nimic . Cuplul va scădea la turații mici . Mecanismul este complex , depinde și de capabilitatea de curent a etajului de comandă și de inductanța motorului  respectiv de frecvența PWM ( În principiu , cu cât frecvența este mai mică , cu atât fenomenul este mai redus ) . Nu trebuie uitat că alimentat direct de la o sursă de tensiune continuă motorul absoarbe un curent mai mare când scade turația - asta permite cuplului să crească . Aici , din motivele de mai sus și poate și din altele , acest lucru nu este posibil.

Soluția este închiderea într-o buclă de control a turației .

Link to comment

Mai întâi ar trebui să dai detalii - motorul , sursa , etc. Văd că în schemă e 100n și tu zici 10n ....

Dar răspunsul scurt ți l-am dat mai sus . Nu se poate rezolva cu această schemă. Poți cel mult să reduci amploarea problemei.

Link to comment

Ma gandeam la C1 care in schema e de 10nF , cred ca si C2 100nf are influenta in frecventa schemei...vreau sa ameliorez pe cat se poate problema care apare in prima patrime inferioara din cursa potentiometrului, pe masura rotesc potentiometrul, dispare zgomotul si motorul incepe sa functioneze normal

Link to comment

Scuze , n-am fost atent ! C1 poate rămâne de 10n , nu influențează frecvența. 

Cu C2=100n ar trebui să ai o frecvență destul de joasă . 

Problema cu zgomotul nu o pot intui . Posibil să fie un motor cu inerție mică și să lucreze sacadat . În cazul ăsta , într-adevăr mărirea frecvenței PWM ajută dar pierzi dincolo. 

Te-am rugat să pui datele motorului și ale sursei . Nu că aș putea găsi o soluție dar măcar să mai ameliorăm , cum zici .

Bănuiesc că ai diodă paralel pe motor , de care e ?

Edited by UDAR
Link to comment

Da , cu motorul nu m-ai lămurit prea tare - mă așteptam la mai multe date ( turație în gol la tensiune/curent , cuplu nominal/maxim, curent de blocare, etc ) Dar,  în fine ...

Nu ai spus prea multe nici despre sursă dar dacă e cu traf și nu este altă limitare de curent nu mai contează.

Da, e normal , problemele apar la factor de umplere mic adică curent mic . 

Concluzia e deci cea de mai sus - nu se poate cuplu mare la turații mici - cu control direct .  

Ar fi utile și alte păreri , eventual experiențe practice ale colegilor . Eu am lucrat puțin cu motoare , problema am constatat-o dar am luat-o ca atare . La ce am făcut eu nu m-a deranjat.

Edited by UDAR
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.Terms of Use si Guidelines