Jump to content

  • Log In with Google      Sign In   
  • Create Account

Photo

aduino nano


  • Please log in to reply
45 replies to this topic

#1 OFFLINE   fane

fane

    Membru

  • Membru activ
  • PipPip
  • 707 posts
  • Locatie:Neamt

Posted 29 April 2017 - 09:16 AM

pentru inceput va rog sa ma scuzati daca limbajul folosit nu este prea in regula sint la prima experienta cu arduino in definitiv vreau sa fac un gnerator de semnal cu arduino si ad 9850 

la eectronica sint la nivelul avansat asa ca din punct devedere al montajelor nu sint probleme

am achizitionat modulele am montat am incarcat driverele pentru placa dar cind sa incarc sketch-ul

preluat de pe net imi spune ca nu se poate compila pentru placa mea respectiv arduino nano V3 desi

in articolul original de pe net  nik_go.ro sint aceleasi module iar sketch-ul este downladat de pe saitul

indicat intrebarea mea este unde ar fi problema fiid incepator nivel 0 nu iteleg?



Cu_reclama

Cu_reclama
  • Membri

#2 OFFLINE   XAN77

XAN77

    Membru avansat

  • Membru activ
  • PipPipPipPip
  • 2,090 posts
  • Locatie:CT

Posted 29 April 2017 - 09:31 AM

Mergi la file/preferences și bifează la show verbose output during căsuțele compilation și upload. Apoi la compilare va afișa detaliat și vei vedea de fapt ce nu-i convine, așa identifici problema și poți rezolva. Așa pățeam și eu că nu prea le am cu arduino. Posibil să trebuiască editat ceva prin fișierul vreunei librării.



#3 OFFLINE   loleksibolek

loleksibolek

    Amiba

  • Membru activ
  • PipPip
  • 495 posts
  • Locatie:Fagaras

Posted 29 April 2017 - 10:10 AM

Pune o captura cu eroarea ce ti-o afiseaza



#4 OFFLINE   fane

fane

    Membru

  • Membru activ
  • PipPip
  • 707 posts
  • Locatie:Neamt

Posted 29 April 2017 - 02:35 PM

cred ca e placa am incercat cu un sketch simplu si aceiasi eroare error compiing fille for board Arduino Nano iar cind dau info board  BN:unknown board  VID 1A86 PID 7523  SN upload any sketch for it mentionez ca folosesc cablu usb pentru conectare cu pc si win 7



#5 OFFLINE   Liviu M

Liviu M

    -

  • Membru activ
  • PipPipPipPipPip
  • 3,284 posts
  • Locatie:In sat cu Doru

Posted 29 April 2017 - 07:03 PM

Compilarea singura trebuie sa fuctioneze si fara placa conectata la PC. Ce n-o sa functioneze daca nu vede placa e upload-ul (scrierea firmware-ului in ucontroller).

Probabil n-ai instalat toate bibliotecile necesare.

Cum am tot zis pe aici, cand ai erori de compilare si vrei sa fii ajutat, copiaza erorile de compilare aici, sa le vedem si noi.


Edited by Liviu M, 29 April 2017 - 07:03 PM.


#6 OFFLINE   dj_ando_83

dj_ando_83

    Membru

  • Membru activ
  • PipPip
  • 508 posts
  • Locatie:Stalpeni Arges

Posted 29 April 2017 - 07:29 PM

Ce fac eu cand copiez coduri de pe net: copiez codul, ii incarc in Arduino Ide, il verific si urmaresc posibilele erori. De cele mai multe ori este posibil sa nu am libraria necesara. Caut libraria care imi trebuie, o incarc si verific iar. Daca codul este bun la final, ma apuc de montaj. 

PS- de multe ori am patit sa uit sa schimb placa de devoltare sau sa nu imi faca contact mufa usb. 



#7 OFFLINE   valentin marcarian

valentin marcarian

    Nou venit

  • Membru activ
  • Pip
  • 29 posts
  • Locatie:Brasov

Posted 29 April 2017 - 10:08 PM

fane: de obicei cand iei de pe net codul sursa pentru mediul arduino contine caractere speciale cum ar fi "^M" pe care nu-l vezi. Aceste caractere genereaza erori la compilare. In meniu la Tools ai "Fix Encodind & Reload." Clicuieste treaba asta si o sa-ti apara aceste caractere la incepulul/sfarsitul liniilor de cod. Trebuie sa le elimini. Procedura trebuie repetata de 2-3 ori. Din prima nu mi-a functionat nici mie.

Revino cu un raspuns.



#8 OFFLINE   fane

fane

    Membru

  • Membru activ
  • PipPip
  • 707 posts
  • Locatie:Neamt

Posted 01 May 2017 - 05:48 PM

am ajuns la concluzia ca schetch-ul e cu probleme am incercat sketchuri din exemplele ide-ului si merg ambee placi inclusiv perifericele incerc sa il descarc din alte surse sa vad



#9 OFFLINE   loleksibolek

loleksibolek

    Amiba

  • Membru activ
  • PipPip
  • 495 posts
  • Locatie:Fagaras

Posted 01 May 2017 - 06:49 PM

O sa-ti repet :pune eroarea afisata sau chiar schetch-ul..E posibil sa nu ai vreo librarie instalata



#10 OFFLINE   fane

fane

    Membru

  • Membru activ
  • PipPip
  • 707 posts
  • Locatie:Neamt

Posted 02 May 2017 - 07:19 AM

atasez scketch-ul carenuil pot compila

Attached Files



#11 OFFLINE   valentin marcarian

valentin marcarian

    Nou venit

  • Membru activ
  • Pip
  • 29 posts
  • Locatie:Brasov

Posted 02 May 2017 - 11:24 AM

fane: Am testat scketch-ul prezentat de tine. Functioneaza perfect si se poate compila.

In arhiva ai un folder "libraries". Copiaza din el folderul Rotary in locatia unde ai instalat arduino IDE in folderul libraries.

Trebuie sa ai ceva de genul : C:\Program Files\Arduino\libraries\Rotary

Apoi totul va fi functional.

Spor la butonat.



#12 OFFLINE   valentin marcarian

valentin marcarian

    Nou venit

  • Membru activ
  • Pip
  • 29 posts
  • Locatie:Brasov

Posted 06 May 2017 - 01:35 PM

fane: asteptam un feedback de la tine.



#13 OFFLINE   MifTy

MifTy

    Insuficient Curentat

  • Membru activ
  • PipPipPipPipPip
  • 5,742 posts
  • Locatie:ConstanĊ£a

Posted 13 May 2017 - 09:56 PM

cred ca e placa am incercat cu un sketch simplu si aceiasi eroare error compiing fille for board Arduino Nano iar cind dau info board  BN:unknown board  VID 1A86 PID 7523  SN upload any sketch for it mentionez ca folosesc cablu usb pentru conectare cu pc si win 7

să ghicesc: ai un Nano chinezesc, cu CH340G, şi nu ai instalat driverele? :d



#14 OFFLINE   fane

fane

    Membru

  • Membru activ
  • PipPip
  • 707 posts
  • Locatie:Neamt

Posted 15 July 2017 - 03:49 PM

imi cer scuze ca nu am mai dat nici un semn dar din cauza unor probleme de sanatate am sistat lucrarile cu arduino acum incerc sa ma joc cu un afisaj tft si nu reusesc nici cum cu sketciurile din librarii csl car leam luat de pe net spune ca nu le poate compila pt nano

iar cele din exampe imi face displaiul numai alb cu licariri de luminozitate .nu am gasit decit putine scheme de conectare a displaiului cu nano si cred ca aici am probleme . am doua displaiuri touch pe unul scrie tftlcd for ard.uno spiflash iar pe celalalt 2,4 tft lcd shield

marcajele la pini sint amindoua la fel si au si slot de card intrebarea e de unde pot lua scheme de conectare si eventul schetch-uri pentru demo?



Cu_reclama

Cu_reclama
  • Membri

#15 OFFLINE   GeoMar

GeoMar

    Membru avansat

  • Membru activ
  • PipPipPipPip
  • 2,182 posts
  • Locatie:Mereni - Teleorman

Posted 15 July 2017 - 10:22 PM

Pai daca afisajul tau TFT este asemanator cu asta al meu, pe spate se vad notatiiile pinilor,

Ii conectezi la arduino Nano conform pinilor numerotati pe LCD ca sa corespunda cu cei de la Nano.

In poza a doua se vad notatiile LCD-ului TFT, nu se vad toti pinii, eu am pozat ca ma interesau integratele ce tip sunt.

 

LCD TFT:

 

tft_1.jpg

 

tft_2.jpg






4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users